Erroring iOS builds
Incident Report for Expo
Resolved
None of the problems are recurring after our most recent deployment.
Posted Jan 22, 2018 - 19:58 PST
Update
We've deployed the fix and are seeing successful builds
Posted Jan 22, 2018 - 17:59 PST
Update
Many of the builders are encountering another problem which leaves them unable to sign IPAs. We know the cause of the problem and are deploying a fix.
Posted Jan 22, 2018 - 17:15 PST
Update
The new deployment of builders has a new problem, visible in your build logs as `TypeError: Cannot read property '0' of undefined`. We've identified the cause and are deploying a fix.
Posted Jan 22, 2018 - 15:43 PST
Update
The error rate remains normal. We're planning to deploy a corrected build and to watch it closely.
Posted Jan 22, 2018 - 14:58 PST
Update
The error rate of new iOS builds seems to have dropped to normal.
Posted Jan 22, 2018 - 14:02 PST
Monitoring
The rollback is complete. We're monitoring new builds as they come in.
Posted Jan 22, 2018 - 13:53 PST
Identified
We've confirmed that the deployment of our iOS builders is linked to the elevated error rate and are working to roll it back.
Posted Jan 22, 2018 - 13:32 PST
Investigating
We recently pushed a change to our iOS app builders and are seeing an elevated number of errors on that platform.
Posted Jan 22, 2018 - 12:50 PST